Jostle's platform is currently unavailable

Incident Report for Jostle - CA

Resolved

Jostle's platform is available again.
Posted Mar 13, 2023 - 10:20 PDT

Investigating

We are currently investigating and will update status when information is available.
Posted Mar 13, 2023 - 10:19 PDT